Author Topic: Windows 10 Professional Spring Update Issue (Resolved)  (Read 390 times)

Alaric

  • Newbie
  • *
  • Posts: 29
    • View Profile
Windows 10 Professional Spring Update Issue (Resolved)
« on: June 01, 2018, 09:32:10 »
If, like us, you run your scoring system on a second-user laptop that happens to be running Windows 10 Professional, rather than the more common 'Home Premium' version, then beware that since the big 'Spring Update', which installed on our laptop a few days ago, the BridgePals system has stopped working.  I haven't had time to investigate yet, but I am fairly certain that the problem has been caused by the Microsoft Server once again taking precedence over the Apache Server, which is critical to the running of the BridgePals system. We hit the same problem when the laptop first updated from Windows 7 Professional to Windows 10 Professional, and if it is indeed a re-occurrence of that same problem then the salvation is that there is a solution and it is well documented both on this forum and in my own notes.  I will not get a chance to test out the theory for a few days, but I will post progress updates here.

johng

  • Administrator
  • *****
  • Posts: 75
    • View Profile
Re: Windows 10 Professional Spring Update Issue (Resolved)
« Reply #1 on: June 01, 2018, 20:00:59 »
It used to be the case that other Windows components could compete with the Apache Server for the use of port 80, and that this could prevent the BridgePal system from operating. However, for this reason I changed the port number used by Apache from 80 to 1357 a long time ago. Port 1357 is not used by any Windows services so I don't believe this can be the reason why you are having problems following the Windows update.

Is it possible that the Windows update has changed the firewall settings and that this is blocking messages from the BridgePal units to the PC ? I suggest you test this by temporarily disabling the firewall and see if this is the problem. If this still doesn't work then try opening a browser window on the PC and enter the url http://127.0.0.1:1357/BridgePal.php . If you get a BridgePal response page then this certainly indicates that the apache server is running and is indicative of some kind of network problem.

You could also check whether the BridgePals are receiving broadcast messages from the PC. Start BridgeScore on the PC, this will automatically start bridgepalBroadcast.exe (you should see a minimised window on the Windows taskbar). On a BridgePal device start the BridgePal app and select "Find BridgePal Server" from the menu. Watch the device display for 20 seconds. Within that time, if it is receiving broadcast messages, you should see a message reporting the ip address of the PC. If no broadcast messages are being received then you should see a message to this effect.

I assume you haven't switched to a different router since the last successful run ? This could also be a cause of the network problem if the router or firewall is not correctly configured.

John

Alaric

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: Windows 10 Professional Spring Update Issue (Resolved)
« Reply #2 on: June 04, 2018, 21:24:18 »
Hi John
Clicking on the URL for BridgePal.php gives the start screen as you predicted it should.  So the Apache Server is up and running.
I started the laptop app, creating a fictional 3-table movement, started wireless scoring, and switched on one of the phones. I checked the admin / management screen for the router and it has correctly identified two attached devices - the laptop and the phone.  The BridgePal app on the phone gives an error message as below.

"Currently connected to "TP-LINK_B683" {correct for our router} wifi network but received error code-2
(net:ERR_ADDRESS_UNREACHABLE) from BridgePal PC.  Please Retry."  Retry yields the same message.

I tried 'Find BridgePal Server' and after a short think it produced:

"Currently connected to "TP-LINK_B683" wifi network but request to BridgePal PC timed out. Please try again."  There is a Retry option, but after thinking about it for a while, it produces the original message again.

I checked the Firewall settings and the following apps are all allowed for both public and private networks: BridgePal, bridgepalbroadcast, BridgePalPkg120. Is this correct?

[at the time of typing I am using the scoring laptop and  flipping between connecting to the internet to access this forum and connecting to the scoring router to test the App.]

Any further insight?


Alaric

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: Windows 10 Professional Spring Update Issue (Resolved)
« Reply #3 on: June 04, 2018, 21:36:15 »
Postscript: when I fired up a second phone and tried 'Find BridgePal Server' very, very fleetingly it produced a message saying 'Found BridgePal PC' on the correct IP address, minus the :1357, but then it rapidly reverted to the error message mentioned before.

johng

  • Administrator
  • *****
  • Posts: 75
    • View Profile
Re: Windows 10 Professional Spring Update Issue (Resolved)
« Reply #4 on: June 04, 2018, 21:43:29 »
Hi Alaric,

The messages you describe are not from "Find BridgePal Server", they are just the result of the initial request from the BridgePal to the PC failing or timing out. The messages in response to Find BridgePal Server appear on the screen and disappear automatically after two or three seconds. If you watch the screen for 20 seconds you should either see a report of the PC's ip address or a message saying that the PC is not detected. In the latter case it means that either bridgepalBroadcast is not running on the PC (it should be if BridgeScore is running), or else the broadcast messages are not getting through the firewall.

Apache should also be in the list of applications allowed to communicate through the firewall, with access to public and private networks. You didn't mention this, so is it in the list ? If not, then it won't work.

If you choose "Select BridgePal Server" from the BridgePal menu you should be able to see the ip address of the PC that is configured into the BridgePal. This is set by bridgepalBroadcast. Is it the same as the actual ip address of the PC ? If not, then it means that the broadcast messages are either not being sent or not being received. To find the ip address of the PC open a command prompt, type "ipconfig" and look for the ipv4 address under the wireless adapter entry.

Just seen your second reply - try choosing "Select BridgePal Server" on the second phone. You should see the reported ip address in the displayed list (which normally only contains a single entry called "BridgePal"). Tap on that entry and it will generate a request to the PC. Does that still fail , if so I suspect it's a problem with the Apache firewall settings as above.

John






Alaric

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: Windows 10 Professional Spring Update Issue (Resolved)
« Reply #5 on: June 04, 2018, 22:39:22 »
Ah!  I think you have put your finger on it!  The Apache server does not appear to be enabled through the firewall....  Could you remind me of the program name and location, please?  Is it httpd in Apache24/bin?

Thanks

Alaric

Alaric

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: Windows 10 Professional Spring Update Issue (Resolved)
« Reply #6 on: June 04, 2018, 23:36:38 »
Hi
This episode has served to remind me why it is I so hate Microsoft stuff!

The problem is now solved.  Not only had the great Windows Update disabled the Apache Server from the list of permitted apps through the Windows Defender Firewall, it had completely 'zapped' all mention of it in the list of recognized applications!  Just in case anyone else is using Windows 10 Professional, here is a step-by-step solution:

1 Open Settings
2 In the search box enter Firewall
3 Select Windows Defender Firewall
4 Select Allow an application through Windows Defender Firewall
5 Select Change Settings
6 Select Allow another App
7 Navigate to / select C://Apache24/bin/httpd
8 Allow it for both Public and Private Networks, and choose OK
9 Reboot, restart BridgeScore

Thanks for your hints and pointers, John.

johng

  • Administrator
  • *****
  • Posts: 75
    • View Profile
Re: Windows 10 Professional Spring Update Issue (Resolved)
« Reply #7 on: June 05, 2018, 08:49:00 »
Hi Alaric,

Glad it's sorted out. For the benefit of anyone else who might encounter a similar problem: Apache should appear as "Apache Http Server" in the list of apps allowed to communicate through the Windows Firewall.

As well as the method you describe Apache can also be added to the list of firewall exceptions by uninstalling/re-installing the BridgePalServices component from the downloads section of the BridgePal website. This should result in a prompt to unblock the firewall for Apache during installation.

John

Alaric

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: Windows 10 Professional Spring Update Issue (Resolved)
« Reply #8 on: June 06, 2018, 09:56:41 »
Hi John

Ah! One of the first things I did was to upgrade both Bridgescore and BridgePal services - but I upgraded the services rather than uninstall and reinstall......  That way clearly didn't work.....

Alaric

johng

  • Administrator
  • *****
  • Posts: 75
    • View Profile
Re: Windows 10 Professional Spring Update Issue (Resolved)
« Reply #9 on: June 06, 2018, 10:44:18 »
Hi Alaric,

Are you sure it was BridgePalServices that you re-installed, not BridgePal Server (the names are very similar) ?

Re-installing BridgePal Server would not make any difference. However, re-installing BridgePalServices, even without uninstalling it first, would prompt you to unblock the firewall providing that there is no entry for "Apache Http Server" in the windows firewall exceptions list. I have just confirmed this by manually deleting Apache Http Server from the firewall exceptions list and re-installing BridgePalServices. I suspect you won't get the prompt if Apache Http Server is already in the list, even if neither the "private" or "public" checkboxes are ticked for that entry.

John