Author Topic: Windows 10 running BridgePals  (Read 384 times)

Alaric

  • Posts: 39
    • View Profile
Windows 10 running BridgePals
« on: January 17, 2020, 12:13:20 »
As far as I can tell, our problem is a Windows 10 issue - but it briefly adversely affects the running of the BridgePals system. 

Every Club session, without fail, we encounter terrible response issues that tend to last only about 5 - 10 minutes, usually when we reach round two or three when using a 2-board movement.  What appears to happen is that while everyone in the room is occupied with bidding and playing, not much traffic is being generated on the scoring devices, and the laptop concludes that the system is (near) idle so it kicks off some really irritating background process that hogs the processing power and causes a room-wide BridgePals freeze.  Whatever it is that causes it is relatively quick, such that for most of the evening the system runs really smoothly and very well.

We did spot that Windows Defender was starting a scan ten minutes or so into the session, because one had not been run for a long time.  After numerous attempts to stop Windows Defender completely, we 'compromised' with the operating system by routinely manually running a Defender Scan before the club session starts.  They only take 5 minutes, but once they're done, it doesn't try to do one again during the evening. [That can be checked by looking at the report on the last run, which says that it was completed at somewhere around 7.15 p.m. - our sessions start at 7.30.

I don't think our problem is caused by Defender scans, but it is by something equally annoying.  The laptop's apps are completely stripped down to the bare essentials.  We have no other AV software installed, apart from Malwarebytes Free, which only runs on demand. Our Laptop has oudles of RAM given what we expect of it.  Through System Settings, the machine has been told that 'the working day' is from 7 p.m. to 11 p.m. and not to check for / run Windows Updates during this working day.

I'd be very interested to know whether anyone else faces, or faced, the same problem, and if so how / whether they have solved it.

johng

  • Administrator
  • *****
  • Posts: 143
    • View Profile
Re: Windows 10 running BridgePals
« Reply #1 on: January 17, 2020, 19:11:57 »
It's possible that the problem is caused by the windows disk defragmentation service. One of our user clubs experienced similar delays on another BridgePal installation, and this turned out to be the cause. To disable it, type "services" in the windows search box to bring up the list of windows services. Scroll down the list until you find one called "Optimise Drives". Double click on this to show the properties dialog box. Startup type will probably be shown as "Manual", which means it is started by Windows when needed. Change "Startup Type" to "Disabled" and click on "Apply". Let us know if this fixes the problem.

Alaric

  • Posts: 39
    • View Profile
Re: Windows 10 running BridgePals
« Reply #2 on: January 28, 2020, 09:23:05 »
Thanks, John.  I didn't get a chance to try this tip last week, but I'll give it a whirl this coming Thursday and report back.  It certainly sounds plausible / likely.

Alaric

  • Posts: 39
    • View Profile
Re: Windows 10 running BridgePals
« Reply #3 on: February 03, 2020, 07:10:04 »
Well, after a sample of one session, that problem appears to have been resolved!  Thanks very much for the tip, John

Alaric

  • Posts: 39
    • View Profile
Re: Windows 10 running BridgePals
« Reply #4 on: February 06, 2020, 23:57:47 »
Two sessions now, both absolutely fine.  So preventing automatic disk defrags running during the session has had a very noticeable effect on system freezes, which have now been eliminated..